Firewall problem in Windows 7

Hi!

I've just figured out that ZunTzu can't work on Vista anymore while the User Account Control is enabled. I'm pretty sure the same thing is happening with Windows 7.
I suppose there is a security feature that prevent non-administrator applications from receiving UDP packets, although I was unable to find any documentation from Microsoft about that.

I see two workarounds:
- disable the User Account Control
- or run ZunTzu as an administrator

To run ZunTzu as an administrator, open a CMD shell as an administrator using right click, and then run this command:
C:\Users\my account\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ZunTzu Software\ZunTzu.appref-ms
Don't forget to replace 'my account' by your user name.

I'll try to learn more about this issue.

_________________
Jerome, ZunTzu developer. Well I followed your instructions regarding the CMD shell and seem to have got my Windows 7 PC to host!

I even managed to connect using my Vista laptop and my mobile phone acting as a modem, so I think that's cracked it Very Happy

I can't seem to get it working the other way round however (using my Vista laptop to host), but heck this is good enough for me.

Many many thanks once again Jerome!!
Bill Barrett wrote:
Well I followed your instructions regarding the CMD shell and seem to have got my Windows 7 PC to host!


Could you please explain how exactly Bill?

In Windows 7 I tried running "cmd.exe" with C:\Users\my account\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ZunTzu Software\ZunTzu.appref-ms
But that results in an error message.

I tried "run.exe" with the same line which starts the program, but I still cannot host. So I assume the latter is not with administrator rights?
Hi Pokke!
Locate the icon for the Command Prompt tool, in the Accessories folder.
Then make sure you use right click "Run as administrator" to launch it.

_________________
Jerome, ZunTzu developer. Pokke,

If you right-click on the CMD shell as Jerome suggests and get the black box displaying, you should see the line C:\Windows\system32>

Then enter Path followed by C:\Users\my account\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ZunTzu Software\ZunTzu.appref-ms

Once you've done that try and connect, but don't use the IP address that ZunTzu suggests - reverse the numbers. So if (for example) ZunTzu tells you to enter 143.97.45.60 Port 1805, enter 60.45.97.143 Port 1805 instead.

Don't ask me why that works (or even why I tried it in the first place!), but it's solved it for me - I finally managed to get a guy in the States to connect to a game last night Very Happy

Regards, Bill.
Thanks, did not know where to find the command console in windows 7. Embarassed

Now, I cannot start the program with that path. Somehow it does not recognise the space-char in "start programs".

But I tried a "cd C:\Users\my account\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ZunTzu Software\" [enter]
Followed by "ZunTzu.appref-ms" [enter]

I love my old MS-DOS knowlegde! Smile

That worked! It's a bit clumsy and I have no idea why the direct path+program does not seem to work for me while it does for you, but that's not important. I'm so glad that I can host games with ZT again! Makes me eager to continue building gameboxes for it!

Thanks Jerome and thanks Bill!
OK, for those of you who might still struggle with this.

1. Copy the following two lines in an (ASCII) text program (notepad for instance):

cd C:\Users\my account\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ZunTzu Software\
ZunTzu.appref-ms

2. Make sure it's two lines.
3. Change "my account" in the first line into your windows "username".
4. Save the file on your desktop and call it "ZunTzu.bat"


From now on all you have to do is:

5. Right-click on the new file and select "run as administrator"
6. ZunTzu fires up and hooray! You can host!

Thanks a lot guys!
Thanks for these post...im having a serious problem with the windows firewall on my laptop, its not turning on, off, or responding at all, here is a video of what happens thanks

online konto eröffnen
I am using ZT since years. All of the sudden, no way to host any game (and I am already logged as the admin)
This is coming perharps from an update from any other software.
The solution to move UAC to the lowest level is working. So far so good.
Tried with admin rights and with disabled the UAC but still am unable to host online. Does the other party need to do the same? (Login with admin rights/disable UAC) I'm assuming only the host needs to right? And if so has anyone else found another solution or is having the same trouble?
Hi 'ZT Folk' (ZunTzu Person):

I have never actually tried to host or attempt to play online with another ZT Folk. However, I have attempted to have two computers on a network to 'hook-up.' It didn't work Sad

I did attempt to disable the UAC and use Admin rights on both computers. Both were Win10 upgraded from Win7.

Has anyone been recently playing online with another ZT folk using Win7/Win10 computer Question


Regards, Rich
Hi Folks - - has anyone played an online game with Win10?

I am sorry to say I have no one to try this with - would you like to try with me, so I can learn? Confused

PM me if you wish to volunteer. I am in the currently in CST time-zone . . .


Keep making Boxes! Rich