Firewall problem in Windows 7

Do you need help installing or using ZunTzu? Would you like to report a bug?

Moderators: Ichibrothers, Cambronne, Chobham_1980

User avatar
Pokke
021
Posts: 58
Joined: 15 Jan 2009, 23:34

Firewall problem in Windows 7

Post by Pokke »

Hi all,

I used to be an avid fan of our beloved Zun Tzu program.

But recently I bought a new computer with windows 7 (64k).
For some reason I'm unable to make a connection with ZunTzu (and ZunTzu only!) to the internet. "change your firewall settings" is the error message that I get.
Even when I turn the firewall off completely this continues to block my connection.

Does anyone know what might be causing it? Or has a solution for this problem?

Thanks!
Pokke

ps. It's also (and more technical) described here: http://social.answers.microsoft.com/For ... 33bc567e55

ps2. Is Jerome still alive and kicking?
User avatar
Bill Barrett
231
Posts: 343
Joined: 25 May 2008, 13:25

Post by Bill Barrett »

Hi Pokke - good to see you back :D

I don't know how to fix your problem - but I know ZunTzu runs perfectly under Windows 7 (I have 7 64 Ultimate).

I did an in place update of the system over Vista 64 (so ZunTzu was already installed) and have had no problems whatsoever...

I hope you can get it sorted (one extra bonus is that the Vista "black" dice bug is gone :D ).

Good luck!
User avatar
Bill Barrett
231
Posts: 343
Joined: 25 May 2008, 13:25

Post by Bill Barrett »

Hmm, I've just noticed this forum topic:

http://www.zuntzu.com/forum/viewtopic.php?t=1131

It suggests that there may be a problem with installation AFTER Windows 7 (?)
User avatar
Pokke
021
Posts: 58
Joined: 15 Jan 2009, 23:34

Post by Pokke »

Hi Bill, best wishes for you btw! :)

If I understand your last message correctly, you mean the problem only seems to show if one installs ZunTzu from scratch on a Windows 7 pc?
That seems to be the case indeed.

I also wonder: was it not so previously that you could download a setup.exe file and run this locally? Now with windows 7 it does not allow you to do that. If I click on the install button on the zuntzu site, the program gets installed automatically and it's really hard to even find it's location on my pc. Maybe that's what is causing all of this weird behaviour?
bggames01
120
Posts: 38
Joined: 09 Nov 2009, 23:58
Contact:

Post by bggames01 »

I installed ZunTzu from scratch on Windows 7 (32-bit ultimate), and have not had problems connecting to other ZunTzu games. From the link you provided I deduce that you are trying to host a game. Is your PC behind a router or other network device that provides NAT? If so you need to first set up port forwarding before you can host from your PC.
User avatar
Pokke
021
Posts: 58
Joined: 15 Jan 2009, 23:34

Post by Pokke »

bggames01 wrote:I installed ZunTzu from scratch on Windows 7 (32-bit ultimate), and have not had problems connecting to other ZunTzu games. From the link you provided I deduce that you are trying to host a game. Is your PC behind a router or other network device that provides NAT? If so you need to first set up port forwarding before you can host from your PC.
Aha? Yes, I'm behind a router. But what NAT is? I'm but a stupid graphics designer who knows nothing about networks and stuff. :(
But I did follow some instructions I found on a website to play Borderlands, which seemed to need the same port forwarding thing that you mention. So maybe I have to search that page again?
bggames01
120
Posts: 38
Joined: 09 Nov 2009, 23:58
Contact:

Post by bggames01 »

Your router takes your ISP internet IP address and translates it for multiple devices behind the router. If you want to host a ZunTzu game on port 1805 then you will need to tell your router that any traffic that comes on TCP port 1805 from the internet should be forwarded to the local IP address of your PC (most routers use a range like 192.168.x.x). How exactly you do this depends on the make of your router, usually it's done trough the web admin interface of your router (for example, if your PC address is 192.168.2.2 then your router could be at http://192.168.2.1/).
User avatar
Pokke
021
Posts: 58
Joined: 15 Jan 2009, 23:34

Post by Pokke »

I did this to allow Borderlands to host online games. http://portforward.com/english/routers/ ... rlands.htm

I tried to do the same for port 1805 but still I get the "change your firewall settings" even when both firewalls (windows 7 and the router) are turned off.
You're my last bit of hope bggames01! ZunTzu has been such a joy to use for playing (and making gameboxes) that I do miss it a lot.
User avatar
Bill Barrett
231
Posts: 343
Joined: 25 May 2008, 13:25

Post by Bill Barrett »

Pokke,

I misunderstood your difficulties (I thought you couldn't get ZunTzu to run at all), it was only when I too tried to host/connect that I had exactly the same problem!

I couldn't connect on my Vista Laptop either - but I fixed both, just as bggames described. I'm at work at the moment, so can't give you all the details, but I'll try and post again later...
User avatar
Bill Barrett
231
Posts: 343
Joined: 25 May 2008, 13:25

Post by Bill Barrett »

Actually, the news is not that great - I've managed to get a game hosted/connected between my Vista laptop and my Windows 7 PC, but not yet been able to host/connect a game to the wider internet. Ho hum :(
alhay1959
Posts: 1
Joined: 27 Jan 2010, 00:24

Time Out Error

Post by alhay1959 »

I'm running Windows Vista on my new laptop & installed ZunTzu. I get a time out error every time I try to join a game & my opponents get a time out error whe I host. I'm a Luddite concerning omputer problems & need help. Any suggestions?
bggames01
120
Posts: 38
Joined: 09 Nov 2009, 23:58
Contact:

Post by bggames01 »

If your WAN IP is: 194.78.40.55
Your router IP is: 192.168.1.1
(if your router is on 192.168.2.1 or 192.168.3.1 or 192.168.n.1 substitute the relevant 1 for your n)

NOTE: to prevent an IP conflict on your LAN make sure your router DHCP is set to only distribute numbers in range (for example): 192.168.1.25 - 192.168.1.250, make sure that at least 192.168.1.2 is not handed out by DHCP.

Go into Control Panel > Network and Sharing Center > Local Area Connection
. (Properties)
. Select TCP/IPv4
. (Properties)
. Instead of obtain address automatically set it as IP Address: 192.168.1.2, Subnet mask: 255.255.255.0, Default gateway: 192.168.1.1; DNS server: 192.168.1.1
. you can do a restart to be on the safe side after changing this (it should work right away, but windows sometimes doesn't take to it right away in my experience)

Now you can setup your router as in borderlands link you sent:
Server name: ZunTzu
Access Activated: Yes
Public Port: 1805
Protocol: TCP
LAN Port: 1805
Local IP Address: 192.168.1.2
> Apply

Disable all firewalls and security (center) software on your PC (at your own risk).

Tell the other player your IP (194.78.40.55) and port 1805 and they should be able to connect.

If it still doesn't work go trough all steps again. If it still fails something is abnormally wrong. Try connecting the PC to the internet directly bypassing the router to see if that is the problem (WARNING, dangerous without firewall/security software). The other player should then be able to connect directly to 194.78.40.55 and port 1805 and reach your PC. If that also doesn't work something is wrong on your PC. You either have something using port 1805 or blocking it that you don't know about. In that case your best bet might be a completely format and reinstall. I had one Windows XP virtual machine that just wouldn't connect to ZunTzu for no apparent reason, client or host. I ended up using a different windows VM.

If it doesn't work when you hook up your PC directly to the internet (no router), it could also be that Belgacom is blocking port 1805. You could try doing the whole procedure again with a high range port (above 32000), like 48005.

If it is working when you bypass the router something is wrong in the setup of the port forwarding on your router. Go trough all menus to see if there is something you missed. Try to see if it has a DMZ feature for 192.168.1.2 (WARNING this is like connecting your PC to the internet bare without firewall). Maybe your router is broken.

Edit: turning off the firewall on your router might not be a good idea. Depending on the implementation, this might also turn off port forwarding.
Edit: you can also try restarting or even resetting (and reconfiguring) your router
User avatar
Pokke
021
Posts: 58
Joined: 15 Jan 2009, 23:34

Post by Pokke »

Thanks for all the help. I have to admit that most of it goes a bit over my head, DHCP? Connect by bypassing the router? ... :oops:

But anyway:
I managed to host a game on my old windows XP machine again, simply by giving it a fixed IP address.
I did not have to do port forwarding or anything.
Question is: does this mean I can assume the router is configured fine?

If so, the problem must be somewhere within windows 7 or on the windows 7 machine.
Some windows 7 firewall is blocking ZunTzu when hosting, even when I turn the windows firewall off.
Or at least, that's the error message I get.

For now I try to play on the old machine though. But I keep an eye on this thread.
User avatar
Pokke
021
Posts: 58
Joined: 15 Jan 2009, 23:34

Post by Pokke »

Bill Barrett wrote:Actually, the news is not that great - I've managed to get a game hosted/connected between my Vista laptop and my Windows 7 PC, but not yet been able to host/connect a game to the wider internet. Ho hum :(
I tried that as well, and it works. I can join a game that I host on my XP machine. That could be the way to proceed... Hosting on XP, playing on my windows 7 pc and hoping that other folks can join from outside. I'm going to try that now.
Tanakor
Posts: 2
Joined: 21 Feb 2010, 08:17

Post by Tanakor »

Same on Vista: I can't host a game, no matter what I do.
My router let's ZunTzu through without any problem, as I can host a game on my Netbook, which is running XP. It's definitly not a problem of dynamic IP.
Any more ideas?
Post Reply